
 
 
 
 
 
 

Wilcom EmbroideryStudio e4.0N Update 1 

Release Notes 

09 June 2017 

This file contains notes on the Wilcom EmbroideryStudio e4.0N Update 1 release. This update is intended for 

installation with any released version (already installed) of Wilcom EmbroideryStudio e4.0. It contains all 

improvements up to this release. 

Note: Administrative privileges are required to install the software update. If you are installing to a corporate 

network, an administrator password may be required during update installation. 
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Improvements with ES e4.0N Update 1 

The ES e4.0 Update 1 software update enhances and corrects a number of problems, already existing or 

introduced with previous updates. 

Design Library improvements 

New from Selected in Design Library 

The ‘New from Template’ function has been incorporated into the Design Library for greater productivity.  

 

In Design Library, the tool creates a new design based on a selected design or image. It uses whatever 

template is current and works for single or multiple selections. Right-clicking the button allows you to select a 

different template. The new template selection is remembered during the current session and will be used the 

next time the command is invoked.  

Design library refresh 

The Design Library display can now be refreshed with a simple ‘F5’ keypress, the same as Windows Explorer. 

Pressing backspace in search 

Previously, holding the Backspace key to clear a search would jump to the cursor to the beginning of the field 

without deleting the text. This problem has been rectified. 
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Searching for non-native files 

Searching for machine files does not always yield correct results. Problems have also been reported when 

searching for ART and T0? files. A related issue has been the mismatching status of the ‘Showing’ field. These 

problems have been rectified. 

 

Order information 

A problem has occurred with missing order information in the Details pane. This has been rectified. 

 

Browsing the network for large files 

Problems have occurred with abnormal loading when browsing through network folders containing large files. 

This has been rectified. 

Design Library crashes 

Design Library crashes have been reported while carrying out routine operations such as: 

 Editing properties in the Design Properties docker. For instance, updating design status in the Details pane 

and/or Design Properties pane and then saving. 

 The Preview pane can cause the software to crash when selecting a design file while thumbnails are being 

generated. 

 Also reported – application crashes when moving images from one folder to another. 

These problems have been rectified. 

Lettering improvements 

Zigzag with lettering 

Previously, users were unable to apply zigzag stitching to selected lettering via the Stitches toolbar. Zigzag 

was disabled and could not be selected. This problem has been rectified. 
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Character display 

Characters are replaced by a ~ character in the Lettering field when they don’t appear in the font. Selecting 

another font causes the lettering object to be completely removed. This problem has been rectified. 

Non-existent character display 

In the Insert Symbol dialog, non-existent characters are now displayed as squares and used when inserted into 

a design. A ‘fallback character’ is displayed below the blank placeholder character. 

 

Tip: If you want to check whether a character exists in a font, copy the fallback character and paste it into an 

MS Word document. Then try changing fonts until you find one that includes the character. 

3D Futuro embroidery font 

The 3D Futuro embroidery font has been improved and repackaged. 

 

Recommended letter heights 

Recommended letter heights for 3D and some other fonts have been reviewed and the user manual updated 

accordingly. 
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Teamname improvements 

Adding columns to the members list 

There used to be a 10 column limit on the number of team members you could add. You can now add a 

virtually unlimited number of columns. Note, however, that only the first 100 will be saved. 
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Teamname letter spacing 

Teamname letter spacing issues have been resolved in cases where a design contains different numbers of 

names. 

 

Importing teamname lists with additional fields 

A ‘size’ field is often added to teamname lists even though it does not form part of the design. Instead, this field 

allows machinists to ensure they are using the right size garment for the specified name. Previously, additional 

fields were stripped on import. This problem has been rectified. 

 

Manage Teams button 

The Manage Teams button should not be selected by default immediately after the Team Names docker is 

opened. This problem has been rectified. 
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File export for team names 

The file export dialog for team names now displays correctly. 
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Design shifts when saving team names 

When saving a teamname design with ‘Repeated design and team names with Stops’ selected, the design 

gets shifted in the output files. This problem has been rectified. 

Adding lettering art to team names 

You can add lettering art to teamname objects from lettering properties accessed via the teamnames docker. 

Problems have been reported where lettering art is applied but then lost. This issue has been rectified. 

 

Stitching improvements 

Flexi-split with complex fill objects 

Currently flexi-split effect is used mainly with satin stitch. It could always be applied to tatami Input A objects. It 

can now be applied to complex fill tatami objects. 

 

Note: Flexi-split is applied to each ‘segment’ of a complex fill as shown above. 
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Stitch angles 

Problems have been reported when adding stitch angles to embroidery objects. When creating complex fill 

objects with holes, the Stitch Angles tool is disabled. Also, adding stitch angles to closed shapes always results 

in Input A/B objects rather than Complex Turning. These problems have been rectified. 

Visualization improvements 

Stitch Player works with ZSK 

Stitch Player has been enhanced to work with ZSK files. It now provides the option of stopping at color 

changes in the same way as ZSK (formerly ZANGS) embroidery machines would act. 

Viewing bling 

The Show Bling command is currently missing from the Digitizing product level. This problem has been 

rectified. 

 

Reshaping objects on a 4K screen at 200% scaling 

A number of issues have been reported when reshaping objects on a 4K screen at 200% scaling: 

 Unable to reshape a manual or manual triple run object. Node points are not shown. 

 Unable to reshape an individual motif dropped with Use Motif. 

 Unable to reshape a manual sequin object. 

These problems have been rectified. 

Usability improvements 

Color palette scrolling 

In instances where the color palette is full, you need to click the spin box to scroll through the available colors. 

Previously, the palette reverted to first position when you start digitizing. It now remains at the current color 

slot. This allows you to easily select nearby colors. 

Tip: You can always float the color palette to display the full range of colors (max 128). This is more practical 

when using a high resolution (4K) monitor or second monitor. 
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Product registration 

There have been requests to include a ‘Product Registration’ option in the Help menu. This has now been 

added to allow users to both register their product and/or check its current status. If already registered, it will 

display your current serial number and dongle tag number. If not registered, it will walk you through the 

process. 

Kiosk locking 

Some related issues are causing problems when the Kiosk lock setting is activated in the Options dialog: 

 Toolbars are unavailable via the Window > Toolbars menu.  

 Opening designs from Design Library invokes the Kiosk instead of the Wilcom Decoration screen. 

These problems have been rectified. 

Kiosk controls after exiting Kiosk mode 

Some Kiosk controls appear in the Wilcom Decoration window immediately after exiting the Kiosk mode. This 

problem has been rectified. 

Scrolling through items in Product Visualizer 

The mouse scroll-wheel now works correctly and faster when scrolling through the product listing. 

 

PDF printing 

A number of problems have been reported in relation to PDF printing from the Print Preview window. 

 The Print Preview > Print to PDF command ignores the Portrait / Landscape setting. It always creates a 

portrait display. 
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 The software reports an error attempting to read the license for the NovaPDF software after a Windows 10 

update. 

 Similarly, a NovaPDF license error is sometimes reported after starting up the software. 

These problems have been rectified. 

Graphics handling improvements 

CorelDRAW X8 64-bit installation in Graphics mode 

When switching to CorelDRAW Graphics mode, the software previously warned (erroneously) that 

CorelDRAW X8 was not installed. This problem has been rectified. 

Undoing bitmap modifications 

Problems have been reported when attempting to undo repositioning or transformation of large bitmaps 

inserted into the software via CorelDRAW Graphics mode. This has been rectified. 

Undo actions between Wilcom Decoration and CorelDRAW Graphics 

Problems have been reported when undoing actions after switching between Wilcom Decoration and 

CorelDRAW Graphics. These have been rectified. 

File handling improvements 

Hatch e3.6 file format 

The latest release allows ES e4 to read and write Hatch EMB e3.6 file format. The list of supported formats 

now includes: 

 

Automatic machine file naming 

Connection Manager now provides an option for automatic machine file naming. When enabled, the specified 

filename format will be used for all machine connections established in Connection Manager. 
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Where: 

Filename format Filenames take the format <prefix><number>.<extension> 

Prefix ASCII only, no unicode characters. No Windows reserved characters. Length limit 8 
characters. 

Number Numeric only. Range 1 – 99,999,999. 

Interval Interval is numeric only and is the amount the number is incremented each time a file is 
generated. Range is 1 – 99. 

 

Note: When enabled, Kiosk will also use this auto-name specification for all machine files. If not enabled, it will 

use the kiosk machine file definition. 

Language improvements 

Truncation problems in some dialogs have been reported in languages other than English. These have been 

rectified. 
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Pique polo in Spanish interface 

In Spanish language, the fabric type ‘pique polo’ was missing from the auto-fabric settings. This problem has 

been rectified. 

Application crashes when saving user-refined letters 

There have been reports of application crashes when saving a user-refined letter in German or French 

interfaces. This issue has been rectified. 

System improvements 

Icons in the Object Properties docker 

Incorrect icons have appeared in the Object Properties docker when not all options are enabled. This problem 

has been rectified. 

Color changes with Colorway Editor docker 

Problems have occurred when clicking a color in the Colorways list of the Colorway Editor docker. Any 

selected object’s color incorrectly changes. This problem has been rectified. 

Generic Write Error 

‘Generic Write Errors’ have been reported when saving designs incorporating images imported via 

CorelDRAW Graphics. This problem has been rectified. 
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CorelDRAW in ES dockers 

Problems have been reported with CorelDRAW ‘artefacts’ persisting in Wilcom Decoration dockers. These 

have been rectified. 

Using high-end Wacom tablets 

With the initial release of ES e4, the user had to do an extra swipe to obtain a right-click action on high-end 

Wacom tablets. For example, when creating curve points with a digitizing tool. This problem has been rectified. 

Input behaviour is as it was in ES e3. 

Application crashes with packaged teamname sample designs 

When Team Names Advanced is unavailable, there have been reports of application crashes when opening 

packaged teamname samples. This problem has been rectified. 

 

Failure to create empty document 

When a Complex Fill object is created and the design saved (EMB or machine file format), a ‘Failed to create 

empty document’ is displayed when attempting to create a new design. Also most of the UI is grayed out and 

the software unusable until restarted. This has been rectified. 

Communications with the Happy Voyager machine 

Problems have been reported when downloading design files to the Happy Voyager machine via Machine 

Manager. A serial error is shown on the machine panel. This problem has been rectified. 

Internal Envelope Error 

An Internal Envelope Error has been reported in relation to system security. This problem has been rectified. 
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Assistance 

If you encounter a problem with the EmbroideryStudio e4.0 software update, refer to the following sources for 

help: 

 Wilcom EmbroideryStudio e4.0 User Manual – select Help > User Manual. 

 Wilcom EmbroideryStudio e4.0 Onscreen Help – select Help > Onscreen Help 

 Windows help – select Start > Help and Support 

 Windows manual – documentation supplied with your hardware. 

If you are unable to solve a problem, you should contact your Wilcom dealer. Before seeking help, check that 

your PC meets the system requirements, and check the Troubleshooting chapter of the User Manual. 

Contact 

If you have any questions, please contact your local Wilcom dealer or distributor in your country. 

Copyright 

Copyright © 1990-2017 Wilcom Pty Ltd, Wilcom International Pty Ltd. All rights reserved. 

No parts of this publication or the accompanying software may be copied or distributed, transmitted, 

transcribed, stored in a retrieval system or translated into any human or computer language, in any form or by 

any means, electronic, mechanical, magnetic, manual, or otherwise, or disclosed to any third party without the 

express written permission of: 

 Wilcom Pty Ltd. (A.B.N. 62 062 621 943) 

 Level 3, 1-9 Glebe Point Rd, Glebe 

 Sydney, New South Wales, 2037, Australia 

 PO Box 1094 Broadway NSW 2007 

 Phone: +61 2 9578 5100 

 Fax: +61 2 9578 5108 

 Web: http://www.wilcom.com 

TrueView™ and Point & Stitch™ are trademarks of Wilcom Pty Ltd. Portions of the imaging technology of this 

Product are copyrighted by AccuSoft Corporation. The EPS File Import/Export Converter used in this Product 

is copyrighted by Access Softek, Inc. All rights reserved. 

 


