
 
 
 
 
 
 

Wilcom EmbroideryStudio e4.2 Update 2 

Release Notes 

06 November 2019 

This file contains notes on the Wilcom EmbroideryStudio e4.2 Update 2 release. This update is intended for 

installation with any released version (already installed) of Wilcom EmbroideryStudio e4.2. It contains all 

improvements up to this release plus any previous updates. 

Note: Administrative privileges are required to install the software update. If you are installing to a corporate 

network, an administrator password may be required during update installation. 
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Improvements in ES e4.2 Update 2 

EmbroideryStudio e4.2 now provides 64-bit operating system support. It has enhanced features, plus new 

design inclusions. The ES e4.2 Update 2 is a minor update to this release. See below for details… 

Stitch quality improvements 

The ES e4.2 Update 2 software update includes the following stitch quality improvements… 

Tatami lettering stitch issues 

Problems have been reported with tatami stitch in lettering objects. These may occur when digitizing letters 

with satin stitch and then changing to tatami fill. Lettering can take on an unwanted wavy appearance. The 

problem affects both TTF and native embroidery fonts. The issue has been resolved with Update 2. 

 

Count in appliqué tack settings 

Problems have been reported when adjusting appliqué properties. Specifically, changing the count in the tack 

settings for Zigzag or Edge Zigzag appears to have no effect. The issue has been resolved with Update 2. 
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Zigzag stitches with split lap corners in Column C objects 

Problems have been reported with lost zigzag stitches when applying lap corners with split overlaps in some 

designs. This may affect Column C objects offset from the center – e.g. 30% side 1, 70% side 2. The issue has 

been resolved with Update 2. 

 

Un-generated stitching in branched objects 

Problems have been reported when attempting to branch complex fill objects with an offset fill type, and run 

objects. Stitches are un-generated for both objects and the software becomes unstable. The issue has been 

resolved with Update 2. 

Problems in offset generation 

Problems have been reported in the generation of offsets with certain object types. For instance, problems 

occur when using star objects, bling fills, and sequin runs as source objects. Offsets may fail to generate or use 

incorrect stitch types. The issue has been resolved with Update 2. 

 

Lettering quality improvements 

The ES e4.2 Update 2 software update includes the following lettering quality improvements… 
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Poor stitching in small lettering 

Problems have been reported with stitching quality of narrow columns in small lettering objects. Specifically, 

poor stitching can sometimes occur at the end of lettering objects where the column is narrow and the lettering 

small at 6-8mm in height. When lettering is enlarged, the problem disappears. The issue has been resolved 

with Update 2. 

 

Unwanted removal of some lettering objects 

Problems have been reported when changing properties of certain rotated, enveloped, lettering objects. 

Changing fonts or stitch types can cause such objects to be removed. The issue has been resolved with 

Update 2. 

 

Design integrity error with branched fonts 

Problems have been reported when saving branched embroidery objects as letters in custom fonts. When 

branched designs are converted to ‘As Digitized’ letters, subsequent attempts to use them triggers a 

design integrity alert. The issue has been resolved with Update 2. 
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File handling improvements 

The ES e4.2 Update 2 software update includes the following file handling improvements… 

System failure when opening some EMB files 

Crashes have been reported when opening some older EMB files. This appears to have introduced by some 

optimizations in the decoding process. The issue has been resolved with Update 2. 

Opening EMB files containing referenced graphics 

Problems have been reported when opening older EMB files which contain linked (rather than embedded) 

graphics. Failure to locate a linked graphic can cause the system to fail. The issue has been resolved with 

Update 2. 

 

Machine manager crashes when loading DST files 

Problems have been reported with Machine Manager crashes when attempting to load DST files. The issue 

has been resolved with Update 2. 

System improvements 

The ES e4.2 Update 2 software update includes the following system improvements… 

DesignWorkflow now packaged 

DesignWorkflow is now available in EmbroideryStudio e4.2 Update 2. 

Disappearing embroidery objects when switching from CorelDRAW Graphics 

Problems have been reported with the unwanted removal of embroidery objects when switching from 

CorelDRAW Graphics mode. The issue has been resolved with Update 2. However, it may still affect files 
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written previously to the current release – e.g. EMB files written in ES e4.1 or ES e4.2. These designs need to 

be saved and re-opened in the latest version of the software. 

Thumbnail image display in Design Library 

When filtering by graphics in Design Library, thumbnail images are being inverted. Filter by graphic files and 

select – the thumbnail in the docker appears upside down. The issue has been resolved with Update 2. 

 

Software crashes with ‘None’ sequins 

Problems have been reported when using the ‘None’ sequin assignment. For example, assigning ‘None’ to the 

first sequin in a Sequin Run, will cause the software to crash. The issue has been resolved with Update 2. 

 

Help links for several languages 

Full online documentation is only provided for a number of languages. Links to online help have been 

erroneously redirected to page 404 for several languages. While full language support is not currently provided 

for some languages, calls to the online help are now directed to the English documentation.  
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Improvements in ES e4.2 Update 1 

EmbroideryStudio e4.2 now provides 64-bit operating system support. It has enhanced features, plus new 

design inclusions. The ES e4.2 Update 1 is a minor update to this release. See below for details… 

File handling improvements 

The ES e4.2 Update 1 software update includes the following file handling improvements… 

ZSK 1 machine file color issue 

Problems have been reported when exporting designs to ZSK 1 machine file format. When edited in e4.2, 

design colors are sometimes switched. The issue has been resolved with Update 1 

 

Recognition of empty jumps and empty stitches in DST files 

Problems have been reported with incorrect recognition of certain combinations of empty jumps and empty 

stitches in DST files causing design integrity errors. The issue has been resolved with Update 1 

 

Recognition of Auto Connectors and Objects/Outlines when exporting DST 

Problems have been reported when opening DST files with Auto Connectors and Objects/Outlines options 

enabled. The software may hang or crash when re-exporting files to DST or EMB formats. The issue has been 

resolved with Update 1 
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Lettering improvements 

The ES e4.2 Update 1 software update includes the following lettering improvements… 

Adding lettering to older designs 

Problems have been reported when adding text to some older designs. Text fails to be added. In some cases, 

new or duplicated objects are removed when 'Create Text' button is invoked using an old template. The issue 

has been resolved with Update 1 
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Normal and recent font list display 

Problems have occurred in the font list of both Object Properties and Monogramming dockers. The opened font 

list fails to display normal font list and recent font list at the same time. The issue has been resolved with 

Update 1 

Thread color improvements 

The ES e4.2 Update 1 software update includes the following thread color improvements… 

Single-click and double-click changes in Threads and Colorway Editor dockers 

Problems have been experienced with the behavior of the changed thread selection mechanism in both the 

Threads and Colorway Editor dockers. The consensus has been to return to previous behavior. With the 

release of Update 1, thread color selection has reverted as follows… 

• Single-clicking a thread in the Threads docker or Colorway Editor docker simply selects the color. 

• Double-clicking a thread in either docker assigns it to the currently selected color in the Color toolbar and 

updates the Colorway Editor docker accordingly. 

• Typing a code and pressing <Enter> in either docker has the same effect. 

• The Assign Thread button has returned to Threads pane and Threads docker toolbar.  

• The Add Color (+) button on the Color toolbar once again the sole mechanism for adding a color slot to the 

palette. 

Note: The new mechanism for locating color blocks in the design window remains. Namely, click and hold a 

color slot in the Color toolbar to isolate the associated objects… 
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Miscellaneous improvements 

The ES e4.2 Update 1 software update includes the following miscellaneous improvements… 

French text in the German installation 

Some French text appears in the German installation of EmbroideryStudio e4.2. The issue has been resolved 

with Update 1 

Open Design button in Machine Manager 

Problems have been reported with the ‘Open Design’ button in Machine Manager. After opening Machine 

Manager and adding a machine, pressing the Open Design icon or using File > Open... has no effect. The 

issue has been resolved with Update 1 

Unexpected disabling of toolbars & menus 

Problems have been reported with unexpected disabling of toolbars and menus when switching between 

operating modes. If switching from Design Library to Home Screen followed by Wilcom Workspace, toolbars 

and menus become temporarily disabled. The issue has been resolved with Update 1 

Known issues and workarounds 

Since the release of ES e4, some issues have been reported with Design Library. The following workarounds 

are suggested… 

Design Library measurement units 

Design Library displays measurement units according to your PC’s regional measurement settings. However, 

when you change measurement units, these may not necessarily update immediately in Design Library 

wherever it uses indexed data. To fix this in Windows… 

1. Apply regional settings to the System Account… 

• Go to Start > Region. 

• Select Administrative settings. 
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• Click Copy settings. 

• Tick ‘Welcome screen and system accounts’. 

• Click OK. This will apply your regional settings to the System Account so any new designs should show in 

correct units. 

2. For existing designs, rebuild the index as follows… 

• Go to Start > Indexing Options. 

• Click Advanced. 

• Under ‘Troubleshooting’, click Rebuild. All your measurement units should now be consistent. 
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Missing design data in Design Library 

Certain design data – title, width, height, colors, stitches – is not shown correctly in Design Library on some 

PCs. This problem may occur on machines that do not meet minimum requirements. Re-indexing usually helps 

though, so could also be suggested as another workaround. The problem may also occur when software is run 

on virtual machines with sub-spec settings. See System Requirements below. 
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System requirements 

Before you install, or if you experience operating problems, make sure that your computer meets the system 

requirements. 

PC specifications 

Check CPU/RAM as well as hard disk space. The table below provides minimum system requirements. 

Component  Minimum Recommended 

CPU  Intel® Core i3 or AMD Athlon™ FX-60 Latest Intel Core i7 processor (3.2 GHz +) 

Operating 
system 

‡ Microsoft Windows 10, Windows 8.1 or 
Windows 7 64-bit all with latest Updates and 
Service Pack 

Microsoft Windows 10 64-bit Edition all with 
latest Updates and Service Pack 

Browser  IE 11.0 or later Microsoft Edge or later 

Memory  8 GB 16 GB or more 

Hard disk size  80 GB 256 GB or more (Solid State Drive) 

Free disk space † 40 GB 60 GB or more 

Graphics card  Support for Highest Color (32bit) and 
resolution (1600 x 900) 

Support for Highest Color (32bit) and 
resolution (1920 x 1080 or higher)  

2 GB or more of graphics memory (non-
integrated) 

Monitor ¥ 1600 x 900 screen resolution Dual monitors capable of displaying 1920 x 
1080 screen resolution 

Mouse  USB mouse USB mouse 

USB port  Required for software installation and security device. 

Sound card  Required for online video help. 

Internet 
connection 

 Required for product activation and registration. Internet connection may also be required 
during installation in order to download Windows features. 

 

Supported operating systems ‡ 

Since EmbroideryStudio no longer supports Windows® 32-bit operating systems, we recommend updating to 

Windows® 10 (64-bit edition) with latest updates installed. You will, however, need to uninstall any earlier 

versions of CorelDRAW® Graphics Suite. For latest operating system information, visit the Wilcom Support 

Center at www.wilcom.com.au/support. 

Free hard disk space † 

EmbroideryStudio occupies up to 5GB of hard disk space, depending on options installed. CorelDRAW® 

Graphics Suite also takes up an additional 3GB. However, you need additional free space for your applications 

to run smoothly. 

http://www.wilcom.com.au/support
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Screen resolution ¥ 

Some controls may be hidden on the user interface if you run your monitor at low resolutions. The physical size 

of your monitor will have a bearing on the optimum screen resolution. Larger fonts will exacerbate the problem. 

If you experience visibility issues, try adjusting both screen resolution and font size. For example, a resolution 

of 1600 x 900 with a font size of 100% or 125% should be acceptable. 

Power plan 

For best performance make sure your PC is set to high performance power plan… 
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Assistance 

If you encounter a problem with the EmbroideryStudio e4 software update, refer to the following sources for 

help: 

• Wilcom EmbroideryStudio e4 online help – select Help > Product Help 

• Wilcom EmbroideryStudio e4 user documentation – select Help > Reference Manual. 

• Windows help – select Start > Help and Support 

• Windows manual – documentation supplied with your hardware. 

Note: Before seeking help, check that your PC meets the above system requirements. 

Contact 

If you have any questions, please contact your local Wilcom dealer or distributor in your country. For technical 

support please visit http://help.wilcom.com. 

Copyright 

Copyright © 2019 Wilcom International Pty Ltd. All rights reserved. 

No parts of this publication or the accompanying software may be copied or distributed, transmitted, 

transcribed, stored in a retrieval system or translated into any human or computer language, in any form or by 

any means, electronic, mechanical, magnetic, manual, or otherwise, or disclosed to any third party without the 

express written permission of: 

 Wilcom International Pty Ltd. (a.c.n. 119 508 575) 

 Level 3, 1-9 Glebe Point Rd, Glebe 

 Sydney, New South Wales, 2037, Australia 

 PO Box 1094 Broadway NSW 2007 

 Phone: +61 2 9578 5100 

 Fax: +61 2 9578 5108 

 Web: http://www.wilcom.com 

TrueView and Point & Stitch are trademarks of Wilcom Pty Ltd. The EPS File Import/Export Converter used in 

this product is copyrighted by Access Softek, Inc. All rights reserved. The Code 39 TTF font, FREE3OF9.TTF, 

has been kindly supplied free of charge by Matthew Welch. 

http://help.wilcom.com/
http://www.wilcom.com/

